summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-05 15:16:59 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-05 15:26:04 +0200
commita19d63e8f42e232ccb5188bf12415c852f83afb2 (patch)
treed46734788b0b82ec56cd74212f8c683ceed3ef82
parent6eee2f7b9ac73fd53ce88d382b4bfd8161c4e74c (diff)
downloadpatches-a19d63e8f42e232ccb5188bf12415c852f83afb2.tar
patches-a19d63e8f42e232ccb5188bf12415c852f83afb2.tar.gz
gnu: Add gpredict.
* gnu/packages/astronomy.scm (gpredict): New variable.
-rw-r--r--gnu/packages/astronomy.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ec90eba974..a02dd04140 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 by Amar Singh <nly@disroot.org>
;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
+;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,8 @@
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages image)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
@@ -344,3 +347,45 @@ All of the major planets and most satellites can be drawn and different map
projections are also supported, including azimuthal, hemisphere, Lambert,
Mercator, Mollweide, Peters, polyconic, orthographic and rectangular.")
(license license:gpl2+)))
+
+(define-public gpredict
+ (package
+ (name "gpredict")
+ (version "2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/csete/gpredict/releases"
+ "/download/v" version
+ "/gpredict-" version ".tar.bz2"))
+ (sha256
+ (base32 "0hwf97kng1zy8rxyglw04x89p0bg07zq30hgghm20yxiw2xc8ng7"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl)
+ ("glib" ,glib)
+ ("goocanvas" ,goocanvas)
+ ("gtk+" ,gtk+)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ ;; Remove reference to non-existent file.
+ (substitute* "po/POTFILES.in"
+ (("src/gtk-sat-tree\\.c")
+ ""))
+ #t)))))
+ (synopsis "Satellite tracking and orbit prediction application")
+ (description
+ "Gpredict is a real-time satellite tracking and orbit prediction
+application. It can track a large number of satellites and display their
+position and other data in lists, tables, maps, and polar plots (radar view).
+Gpredict can also predict the time of future passes for a satellite, and
+provide you with detailed information about each pass.")
+ (home-page "http://gpredict.oz9aec.net/index.php")
+ (license license:gpl2+)))