summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-01 21:18:04 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-05 21:51:32 +0200
commit9732910dd336e9bca56991a0630619bc1578d2af (patch)
treefad79aebe5e01273a14686d2b01dffa1a4cecbf7
parentb6b3a6a6c4f00815da576912907c7bdbf02ca11a (diff)
downloadpatches-9732910dd336e9bca56991a0630619bc1578d2af.tar
patches-9732910dd336e9bca56991a0630619bc1578d2af.tar.gz
gnu: Add liblinphone.
* gnu/packages/linphone.scm (liblinphone): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/linphone.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 50cb2943f0..265c33e454 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -24,6 +24,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages gnome)
#:use-module (gnu packages graphviz)
@@ -31,6 +32,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages java)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages telephony)
@@ -367,3 +369,49 @@ is responsible for receiving and sending all multimedia streams in Linphone,
including media capture, encoding and decoding, and rendering.")
(home-page "https://gitlab.linphone.org/BC/public/mediastreamer2")
(license license:gpl2+)))
+
+(define-public liblinphone
+ (package
+ (name "liblinphone")
+ (version "3.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://www.linphone.org/releases/sources/linphone"
+ "/linphone-" version ".tar.gz"))
+ (sha256
+ (base32 "0phhkx55xdyg28d4wn8l8q4yvsmdgzmjiw584d4s190sq1azm91x"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test target
+ #:configure-flags
+ (list
+ "-DENABLE_STATIC=NO"))) ; Not required
+ (native-inputs
+ `(("dot" ,graphviz)
+ ("doxygen" ,doxygen)
+ ("gettext" ,gettext-minimal)
+ ("iconv" ,libiconv)
+ ("python" ,python)
+ ("xml2" ,libxml2)
+ ("zlib" ,zlib)))
+ (inputs
+ `(("bctoolbox" ,bctoolbox)
+ ("belcard" ,belcard)
+ ("bellesip" ,belle-sip)
+ ("bzrtp", bzrtp)
+ ("mediastreamer2" ,mediastreamer2)
+ ("ortp" ,ortp)
+ ("pystache" ,python-pystache)
+ ("six" ,python-six)
+ ("sqlite" ,sqlite)
+ ("udev" ,eudev)))
+ (synopsis "Belledonne Communications Softphone Library")
+ (description "Liblinphone is a high-level SIP library integrating
+all calling and instant messaging features into an unified
+easy-to-use API. It is the cross-platform VoIP library on which the
+Linphone application is based on, and that anyone can use to add audio
+and video calls or instant messaging capabilities to an application.")
+ (home-page "https://gitlab.linphone.org/BC/public/liblinphone")
+ (license license:gpl2+)))