summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-04-03 00:44:07 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-05 10:59:13 +0200
commit95856a6e02aacd9a5cc3677720f34ca933b00e9e (patch)
treedfdec51e688f4c6487cf3c7010f1528c6a3e3248
parent37084435d3d104a6de834379ce15eaaefea6396b (diff)
downloadpatches-95856a6e02aacd9a5cc3677720f34ca933b00e9e.tar
patches-95856a6e02aacd9a5cc3677720f34ca933b00e9e.tar.gz
gnu: Add jsonrpc-glib.
* gnu/packages/gnome.scm: (jsonrpc-glib) New variable.
-rw-r--r--gnu/packages/gnome.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f93dd2649c..5954b8cf7c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9958,3 +9958,33 @@ to.")
environment. Its main purpose is the manual transcription of spoken
audio files.")
(license license:gpl3+))))
+
+(define-public jsonrpc-glib
+ (package
+ (name "jsonrpc-glib")
+ (version "3.34.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0j05x4xv2cp3cbmp30m68z8g4rdw7b030ip4wszyfj9ya15v5kni"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("json-glib" ,json-glib)
+ ("glib" ,glib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
+ ("gobject-introspection" ,gobject-introspection)
+ ("vala" ,vala)))
+ (home-page "https://gitlab.gnome.org/GNOME/jsonrpc-glib")
+ (synopsis "JSON-RPC library for GLib")
+ (description "Jsonrpc-GLib is a library to communicate with JSON-RPC based
+peers in either a synchronous or asynchronous fashion. It also allows
+communicating using the GVariant serialization format instead of JSON when
+both peers support it. You might want that when communicating on a single
+host to avoid parser overhead and memory-allocator fragmentation.")
+ (license license:lgpl2.1+)))