summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:19:23 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit84d240172863e293ed25f38469e9676afb3c2aa9 (patch)
treefdd473cb41ca11db831f24de5847b29beb087b8a
parent855d4761a504e217accc85fcc159c70c07dbb951 (diff)
downloadpatches-84d240172863e293ed25f38469e9676afb3c2aa9.tar
patches-84d240172863e293ed25f38469e9676afb3c2aa9.tar.gz
gnu: Add python-scripttest.
* gnu/packages/python.scm (python-scriptest, python2-scripttest): New variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3e71b39daf..5235ced452 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1127,6 +1127,33 @@ and many external plugins.")
(define-public python2-pytest
(package-with-python2 python-pytest))
+(define-public python-scripttest
+ (package
+ (name "python-scripttest")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/s/scripttest/scripttest-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0f4w84k8ck82syys7yg9maz93mqzc8p5ymis941x034v44jzq74m"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-pytest" ,python-pytest)))
+ (home-page "http://pythonpaste.org/scripttest/")
+ (synopsis "Python library to test command-line scripts")
+ (description "Scripttest is a Python helper library for testing
+interactive command-line applications. With it you can run a script in a
+subprocess and see the output as well as any file modifications.")
+ (license expat)))
+
+(define-public python2-scripttest
+ (package-with-python2 python-scripttest))
+
(define-public behave
(package
(name "behave")