summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-03-28 00:46:23 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-04-05 20:43:17 +0200
commit7fe746e071e3177e76dad9e2bcd1d53e87187f1a (patch)
tree4480c8c08138e82d87d0df76c8a5d359ac514626
parentb3b33da07097af1c61d23f662902650dcdeb25af (diff)
downloadpatches-7fe746e071e3177e76dad9e2bcd1d53e87187f1a.tar
patches-7fe746e071e3177e76dad9e2bcd1d53e87187f1a.tar.gz
gnu: python-intervaltree: Update to 3.0.2.
* gnu/packages/bioinformatics.scm (python-intervaltree): Update to 3.0.2. [arguments]: Don't skip the tests, work around the problematic sanity-check instead.
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d69c2aea63..943369b275 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13552,17 +13553,27 @@ allowing the insertion of arbitrary types into the tree.")
(define-public python-intervaltree
(package
(name "python-intervaltree")
- (version "2.1.0")
+ (version "3.0.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "intervaltree" version))
(sha256
(base32
- "02w191m9zxkcjqr1kv2slxvhymwhj3jnsyy3a28b837pi15q19dc"))))
+ "0wz234g6irlm4hivs2qzmnywk0ss06ckagwh15nflkyb3p462kyb"))))
(build-system python-build-system)
- ;; FIXME: error when collecting tests
- (arguments '(#:tests? #f))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; pytest seems to have a check to make sure the user is testing
+ ;; their checked-out code and not an installed, potentially
+ ;; out-of-date copy. This is harmless here, since we just installed
+ ;; the package, so we disable the check to avoid skipping tests
+ ;; entirely.
+ (add-before 'check 'import-mismatch-error-workaround
+ (lambda _
+ (setenv "PY_IGNORE_IMPORTMISMATCH" "1")
+ #t)))))
(propagated-inputs
`(("python-sortedcontainers" ,python-sortedcontainers)))
(native-inputs