summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-05 01:07:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-05 01:15:45 -0400
commit74c7f367daa554cedeb5f02a00d1cd02acf1584b (patch)
tree1bb63d39c05eef104a87405142b9d8d946253fb8
parent77704cb13e5bebf412297dab764a00849a3cfdc0 (diff)
downloadpatches-74c7f367daa554cedeb5f02a00d1cd02acf1584b.tar
patches-74c7f367daa554cedeb5f02a00d1cd02acf1584b.tar.gz
gsm: Add the -fPIC compiler option.
This is necessary for building mediastream2 (a dependency of Linphone). * gnu/packages/audio.scm (gsm): Add the default CCFLAGS as a make flag, and prepend -fPIC to these. Pass INSTALL_ROOT as a make flag as well, which removes the need to use substitute* in a phase.
-rw-r--r--gnu/packages/audio.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f368fedee7..6d29184592 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 okapi <okapi@firemail.cc>
-;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
@@ -3356,14 +3356,14 @@ code, used in @code{libtoxcore}.")
(build-system gnu-build-system)
(arguments
`(#:test-target "tst"
+ #:make-flags '("INSTALL_ROOT=%output"
+ "CCFLAGS=-fPIC \
+-c -O2 -DNeedFunctionPrototypes=1 -Wall -Wno-comment") ;default options
#:phases
(modify-phases %standard-phases
(add-before 'install 'pre-install
(lambda _
(let ((out (assoc-ref %outputs "out")))
- (substitute* "Makefile"
- (("INSTALL_ROOT\t=")
- (string-append "INSTALL_ROOT\t=\t" out)))
(mkdir-p (string-append out "/inc"))
(mkdir-p (string-append out "/man"))
(mkdir-p (string-append out "/man/man1"))