summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-05 14:46:06 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-05 15:26:04 +0200
commit6eee2f7b9ac73fd53ce88d382b4bfd8161c4e74c (patch)
tree77f332a268c30bc8b6398ddc4a1af06d92ed1a67
parent4391fefc5e3a679825527d4567067f639972473f (diff)
downloadpatches-6eee2f7b9ac73fd53ce88d382b4bfd8161c4e74c.tar
patches-6eee2f7b9ac73fd53ce88d382b4bfd8161c4e74c.tar.gz
gnu: Add goocanvas.
* gnu/packages/gtk.scm (goocanvas): New variable.
-rw-r--r--gnu/packages/gtk.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index df9fc05294..4882a95eb8 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1920,3 +1921,49 @@ anchor windows to a corner or edge of the output, or stretch them across the
entire output. It supports all Layer Shell features including popups and
popovers.")
(license license:expat)))
+
+(define-public goocanvas
+ (package
+ (name "goocanvas")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/goocanvas/"
+ (version-major+minor version)
+ "/goocanvas-" version ".tar.xz"))
+ (sha256
+ (base32 "141fm7mbqib0011zmkv3g8vxcjwa7hypmq71ahdyhnj2sjvy4a67"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib-bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("python-pygobject" ,python-pygobject)))
+ (arguments
+ `(#:configure-flags '("--disable-rebuilds"
+ "--disable-static")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-install-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "configure"
+ (("\\(gi._overridesdir\\)")
+ (string-append "((gi._overridesdir).replace(\\\""
+ (assoc-ref inputs "python-pygobject")
+ "\\\", \\\""
+ (assoc-ref outputs "out")
+ "\\\"))")))
+ #t)))))
+ (synopsis "Canvas widget for GTK+")
+ (description "GooCanvas is a canvas widget for GTK+ that uses the cairo 2D
+library for drawing.")
+ (home-page "https://wiki.gnome.org/GooCanvas")
+ (license license:lgpl2.0)))