summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-05 13:54:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-05 14:16:14 -0400
commit5b05f8e9654ea722270c45c0fd0eead369bc0daf (patch)
treea70f46fe16ffffa908735fe4fcc2639268104c0a
parent95b800e67ca9b6ca6be4f7afd74ddd70286ac852 (diff)
downloadpatches-5b05f8e9654ea722270c45c0fd0eead369bc0daf.tar
patches-5b05f8e9654ea722270c45c0fd0eead369bc0daf.tar.gz
gnu: gsm: Fix installation directory.
This is a follow-up commit to 74c7f367daa, which broke the installation of the bin, lib and share artifacts. * gnu/packages/audio.scm (gsm)[make-flags]: Programmatically build the INSTALL_ROOT make flag so that the %output variable gets properly expanded. Instead of repeating the default CCFLAGS values as a make flag... [phases]: ...add "-fPIC" using substitutes* in a new add-fpic-ccflag phase.
-rw-r--r--gnu/packages/audio.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 68cea0a693..18982b7257 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3356,11 +3356,17 @@ code, used in @code{libtoxcore}.")
(build-system gnu-build-system)
(arguments
`(#:test-target "tst"
- #:make-flags '("INSTALL_ROOT=%output"
- "CCFLAGS=-fPIC \
--c -O2 -DNeedFunctionPrototypes=1 -Wall -Wno-comment") ;default options
+ #:make-flags (list (string-append "INSTALL_ROOT=" %output))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'add-fpic-ccflag
+ (lambda _
+ ;; The -fPIC compiler option is needed when building
+ ;; mediastreamer.
+ (substitute* "Makefile"
+ (("^CCFLAGS.*" all)
+ (string-append all "CCFLAGS += -fPIC")))
+ #t))
(add-before 'install 'pre-install
(lambda _
(let ((out (assoc-ref %outputs "out")))