summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-04-05 12:55:16 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-04-05 14:58:25 +0200
commit4391fefc5e3a679825527d4567067f639972473f (patch)
treeef699dc46663f54b69a79fd40932c7dda9957374
parent044d1478c9a63a64547c9cc320008f8d8fbf6791 (diff)
downloadpatches-4391fefc5e3a679825527d4567067f639972473f.tar
patches-4391fefc5e3a679825527d4567067f639972473f.tar.gz
gnu: gnome-weather: Work around desktop application startup failure.
* gnu/packages/gnome.scm (gnome-weather)[arguments]: Replace Exec= line with gnome-weather.
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5954b8cf7c..257cc5e5a6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7728,6 +7728,17 @@ associations for GNOME.")
("gjs" ,gjs)
("gnome-desktop" ,gnome-desktop)
("libgweather" ,libgweather)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'fix-desktop-file
+ ;; FIXME: "gapplication launch org.gnome.Weather" fails for some reason.
+ ;; See https://issues.guix.gnu.org/issue/39324.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (applications (string-append out "/share/applications")))
+ (substitute* (string-append applications "/org.gnome.Weather.desktop")
+ (("Exec=.*") "Exec=gnome-weather\n"))))))))
(synopsis "Weather monitoring for GNOME desktop")
(description "GNOME Weather is a small application that allows you to
monitor the current weather conditions for your city, or anywhere in the