summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-04 22:00:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-04 22:05:01 -0400
commit084d15656342f6c69a1448c2d41f27e8499bd61d (patch)
tree7d256011e471334df1d4f2506354f78c8b168e32
parenteaa3cb1eb431ee45694d8ce7cb0ea329effcc4bb (diff)
downloadpatches-084d15656342f6c69a1448c2d41f27e8499bd61d.tar
patches-084d15656342f6c69a1448c2d41f27e8499bd61d.tar.gz
gnu: nfs-utils: Fix the shebangs of the Python based tools.
While attempting to debug NFS with 'mountstats' and other Python based tools, I was greeted by the error: bash: /run/current-system/profile/sbin/mountstats: /usr/bin/python: bad interpreter: No such file or directory Add python-wrapper, so that the Python shebangs get rewritten correctly. * gnu/packages/nfs.scm (nfs-utils)[inputs]: Add python-wrapper.
-rw-r--r--gnu/packages/nfs.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/nfs.scm b/gnu/packages/nfs.scm
index 3a8467431d..81eabef493 100644
--- a/gnu/packages/nfs.scm
+++ b/gnu/packages/nfs.scm
@@ -27,6 +27,7 @@
#:use-module (gnu packages kerberos)
#:use-module (gnu packages onc-rpc)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages sqlite)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
@@ -115,7 +116,8 @@
("lvm2" ,lvm2)
("util-linux" ,util-linux)
("mit-krb5" ,mit-krb5)
- ("libtirpc" ,libtirpc)))
+ ("libtirpc" ,libtirpc)
+ ("python-wrapper" ,python-wrapper))) ;for the Python based tools
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://www.kernel.org/pub/linux/utils/nfs-utils/")