summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-04-05 22:03:25 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-05 22:03:25 +0200
commit02b32cdda68495344d8e5521db5aeaf5add03797 (patch)
treebf8c854f20db1f6e6e4621181ada371226f1735b
parent9732910dd336e9bca56991a0630619bc1578d2af (diff)
downloadpatches-02b32cdda68495344d8e5521db5aeaf5add03797.tar
patches-02b32cdda68495344d8e5521db5aeaf5add03797.tar.gz
gnu: liblinphone: Add features.
* gnu/packages/linphone.scm (liblinphone)[arguments]<#:configure-flags>: Add features. <#:phases>[patch]: New phase. [inputs]: Add glib, gtk2, notify. [propagated-inputs]: Add murrine.
-rw-r--r--gnu/packages/linphone.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 265c33e454..2b0d6036fe 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -26,8 +26,11 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnome-xyz)
#:use-module (gnu packages graphviz)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages pulseaudio)
@@ -387,7 +390,22 @@ including media capture, encoding and decoding, and rendering.")
`(#:tests? #f ; No test target
#:configure-flags
(list
- "-DENABLE_STATIC=NO"))) ; Not required
+ (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
+ (string-append (assoc-ref %build-inputs "gtk2")
+ "/lib/gtk-2.0/include"))
+ (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
+ (string-append (assoc-ref %build-inputs "glib")
+ "/lib/glib-2.0/include"))
+ "-DENABLE_STATIC=NO" ; Not required
+ "-DENABLE_GTK_UI=YES") ; For Legacy UI
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "gtk/main.c"
+ (("#include \"liblinphone_gitversion.h\"")
+ ""))
+ #t)))))
(native-inputs
`(("dot" ,graphviz)
("doxygen" ,doxygen)
@@ -401,12 +419,17 @@ including media capture, encoding and decoding, and rendering.")
("belcard" ,belcard)
("bellesip" ,belle-sip)
("bzrtp", bzrtp)
+ ("glib" ,glib)
+ ("gtk2" ,gtk+-2)
("mediastreamer2" ,mediastreamer2)
+ ("notify" ,libnotify)
("ortp" ,ortp)
("pystache" ,python-pystache)
("six" ,python-six)
("sqlite" ,sqlite)
("udev" ,eudev)))
+ (propagated-inputs
+ `(("murrine" ,murrine))) ; Required for GTK UI
(synopsis "Belledonne Communications Softphone Library")
(description "Liblinphone is a high-level SIP library integrating
all calling and instant messaging features into an unified