summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-03 22:57:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-03 23:01:45 -0400
commite8a1c5af8421910d80e6bf4ecc6440e9200c76b1 (patch)
treebb227ab34498de62da215a2f61d6e26c8bfea3d6
parentd24e598a7840a6ab70424e27fd858d9bc0ae12b1 (diff)
downloadpatches-e8a1c5af8421910d80e6bf4ecc6440e9200c76b1.tar
patches-e8a1c5af8421910d80e6bf4ecc6440e9200c76b1.tar.gz
gnu: spandsp: Disable parallel build.
The build could otherwise fail non-deterministically. Reported-by: Raghav Gururajan <raghavgururajan@disroot.org> * gnu/packages/telephony.scm (spandsp)[arguments]: Set parallel-build? to false.
-rw-r--r--gnu/packages/telephony.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 95d3ab53ca..96909b00b6 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -109,6 +109,7 @@
(outputs '("out" "doc" "static")) ;doc contains HTML documentation
(arguments
`(#:configure-flags '("--enable-doc=yes" "--enable-tests=yes")
+ #:parallel-build? #f ;non-deterministic build failures may occur otherwise
#:parallel-tests? #f ;fails removing the same the files twice otherwise
#:phases (modify-phases %standard-phases
(add-after 'unpack 'patch-configure.ac