summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2017-02-20 01:37:35 -0500
committerRicardo Wurmus <rekado@elephly.net>2017-10-10 23:09:40 +0200
commitbb3b4b4ee98d15273c34a8bd7bf8e8a3a07d7390 (patch)
tree70160d76a29071a68359172040f6b253bcffb3a9
parent4b8b4418e609b5e0bfb6efbc11ac28deaa437e80 (diff)
downloadpatches-bb3b4b4ee98d15273c34a8bd7bf8e8a3a07d7390.tar
patches-bb3b4b4ee98d15273c34a8bd7bf8e8a3a07d7390.tar.gz
gnu: Add python-attrs.
* gnu/packages/python.scm (python-attrs, python2-attrs): New variables. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 93bfe18526..f4010b6928 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
-;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
+;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -14228,6 +14228,32 @@ Python. It is based on Parsing Expression Grammars, PEG. With pyPEG you can
parse many formal languages.")
(license license:gpl2)))
+(define-public python-attrs
+ (package
+ (name "python-attrs")
+ (version "17.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "attrs" version))
+ (sha256
+ (base32
+ "04gx08ikpk26wnq22f7l42gapcvk8iz1512r927k6sadz6cinkax"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-hypothesis" ,python-hypothesis)
+ ("python-zope-interface" ,python-zope-interface)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/python-attrs/attrs/")
+ (synopsis "Attributes without boilerplate")
+ (description "@code{attrs} is a Python package with class decorators that
+ease the chores of implementing the most common attribute-related object
+protocols.")
+ (license license:expat)))
+
+(define-public python2-attrs
+ (package-with-python2 python-attrs))
+
(define-public python2-cliapp
(package
(name "python2-cliapp")