summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-04-03 10:06:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-03 10:56:42 +0200
commit9ec27360af620fcbab8139e4d8963cccddda2b55 (patch)
treed571faa4151f4ea542f2c531ca31053799b1718d
parent24f4263d06561ee9754283348f6688a46ccace55 (diff)
downloadpatches-9ec27360af620fcbab8139e4d8963cccddda2b55.tar
patches-9ec27360af620fcbab8139e4d8963cccddda2b55.tar.gz
gnu: Add muchsync.
* gnu/packages/mail.scm (muchsync): New variable.
-rw-r--r--gnu/packages/mail.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index ed14360066..2d0e25655f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -82,6 +83,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages libevent)
@@ -1074,6 +1076,38 @@ and search library.")
(define-public python2-notmuch
(package-with-python2 python-notmuch))
+(define-public muchsync
+ (package
+ (name "muchsync")
+ (version "5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.muchsync.org/src/"
+ "muchsync-" version ".tar.gz"))
+ (sha256
+ (base32 "1k2m44pj5i6vfhp9icdqs42chsp208llanc666p3d9nww8ngq2lb"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("ghc-pandoc" ,ghc-pandoc)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libcrypto" ,openssl)
+ ("notmuch" ,notmuch)
+ ("sqlite" ,sqlite)
+ ("xapian" ,xapian)))
+ (home-page "http://www.muchsync.org/")
+ (synopsis "Synchronize notmuch mail across machines")
+ (description
+ "Muchsync brings Notmuch to all of your computers by synchronizing your
+mail messages and Notmuch tags across machines. The protocol is heavily
+pipelined to work efficiently over high-latency networks such as mobile
+broadband. Muchsync supports arbitrary pairwise synchronization among
+replicas. A version-vector-based algorithm allows it to exchange only the
+minimum information necessary to bring replicas up to date regardless of which
+pairs have previously synchronized.")
+ (license gpl2+)))
+
(define-public getmail
(package
(name "getmail")