summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-03 11:16:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-03 11:25:16 -0400
commit91b3f58de83d303548017ac5bf1d9e2f86f38a6a (patch)
tree9c540a6c4070d4916f6a3a633bdc8a0024af14fd
parenta9d58a801ef65c93d1f1253120646d50ce81de40 (diff)
downloadpatches-91b3f58de83d303548017ac5bf1d9e2f86f38a6a.tar
patches-91b3f58de83d303548017ac5bf1d9e2f86f38a6a.tar.gz
gnu: Add python-diskcache.
* gnu/packages/python-xyz.scm (python-diskcache): New variable.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 75b74ecde7..0bdf165119 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1208,6 +1208,25 @@ abstractions to different hardware devices, and a suite of utilities for
sending and receiving messages on a CAN bus.")
(license license:gpl3+)))
+(define-public python-diskcache
+ (package
+ (name "python-diskcache")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "diskcache" version))
+ (sha256
+ (base32
+ "1q2wz5sj16zgyy1zpq516qgbnfwsavk1pl2qks0f4r62z5cmmvmw"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;test suite not included in the release
+ (home-page "http://www.grantjenks.com/docs/diskcache/")
+ (synopsis "Disk and file backed cache library")
+ (description "DiskCache is a disk and file backed persistent cache.")
+ (license license:asl2.0)))
+
(define-public python-capturer
(package
(name "python-capturer")