summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaga Malleswari <nagamalli@riseup.net>2020-04-04 18:40:58 +0530
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-04 15:26:06 +0200
commit600b6d4378b0de37b9f1dc4fdb81782e1482f2f7 (patch)
treed40fbb52270fc978ff604cb5543be8f20f4c2ea5
parenta5a2d79b91b07c231622a92f9322ea7ebf5d9c77 (diff)
downloadpatches-600b6d4378b0de37b9f1dc4fdb81782e1482f2f7.tar
patches-600b6d4378b0de37b9f1dc4fdb81782e1482f2f7.tar.gz
gnu: Add r-asd.
* gnu/packages/cran.scm (r-asd): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f0dc124681..98f05ed54b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2020 Todor Kondić <tk.code@protonmail.com>
;;; Copyright © 2020 Danjela Lura <danielaluraa@gmail.com>
+;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21054,3 +21055,26 @@ where tcltk is present are supported.")
with R, controlling a remote R session (the server) from a local one (the
client).")
(license license:bsd-2)))
+
+(define-public r-asd
+ (package
+ (name "r-asd")
+ (version "2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "asd" version))
+ (sha256
+ (base32
+ "0p3r4qjam3sl3rpcilb0pgx4xx3ly71xqnvkv31vzjs885lgxz4l"))))
+ (properties `((upstream-name . "asd")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mvtnorm" ,r-mvtnorm)))
+ (home-page "https://cran.r-project.org/web/packages/asd")
+ (synopsis "Simulations for Adaptive Seamless Designs")
+ (description
+ "This package provdes means to run simulations for adaptive seamless
+designs with and without early outcomes for treatment selection and
+subpopulation type designs.")
+ (license license:gpl3)))