summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-04 19:57:50 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-04 20:03:06 +0200
commit5ef1b17578cc247df10257d982a4cd670a74a94a (patch)
tree1d0ef42b51916b2b2e9576c4c8d6d8ab5cfa1b49
parent3cea55078857ecd8ca67fd7cf4eaebb13fb6d9d3 (diff)
downloadpatches-5ef1b17578cc247df10257d982a4cd670a74a94a.tar
patches-5ef1b17578cc247df10257d982a4cd670a74a94a.tar.gz
gnu: qgis: Fix some plugins.
* gnu/packages/geo.scm (qgis)[arguments]: Add a 'wrap-gis' phase to set the environment variables required by some plugins.
-rw-r--r--gnu/packages/geo.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index e895c064ba..86385c14ae 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1933,6 +1933,22 @@ growing set of geoscientific methods.")
(add-after 'wrap-python 'wrap-qt
(lambda* (#:key outputs #:allow-other-keys)
(wrap-qt-program (assoc-ref outputs "out") "qgis")
+ #t))
+ (add-after 'wrap-qt 'wrap-gis
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (saga (string-append (assoc-ref inputs "saga") "/bin"))
+ (grass-version ,(package-version grass))
+ (grass-majorminor (string-join
+ (list-head
+ (string-split grass-version #\.) 2)
+ ""))
+ (grass (string-append (assoc-ref inputs "grass")
+ "/grass" grass-majorminor)))
+ (wrap-program (string-append out "/bin/qgis")
+ `("PATH" ":" prefix (,saga))
+ `("QGIS_PREFIX_PATH" = (,out))
+ `("GISBASE" = (,grass))))
#t)))))
(inputs
`(("exiv2" ,exiv2)