summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-12 23:00:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-13 00:44:57 +0200
commit5ad0a4522116007420aeb288f76da241f43cb6bf (patch)
tree1f6deca9ecbc44e08db0935569c6a1e798ca21a4
parentbcb22b3624e677231b50029fea63e3b6e4978b2d (diff)
downloadpatches-5ad0a4522116007420aeb288f76da241f43cb6bf.tar
patches-5ad0a4522116007420aeb288f76da241f43cb6bf.tar.gz
gnu: python-matplotlib-documentation: Add missing input.
* gnu/packages/python-xyz.scm (python-matplotlib-documentation)[native-inputs]: Add python-sphinx-copybutton. (python2-matplotlib-documentation)[native-inputs]: Remove python-sphinx-copybutton.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1a4c804f37..4541604873 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3960,6 +3960,7 @@ toolkits.")
`(("python-matplotlib" ,python-matplotlib)
("python-colorspacious" ,python-colorspacious)
("python-sphinx" ,python-sphinx)
+ ("python-sphinx-copybutton" ,python-sphinx-copybutton)
("python-sphinx-gallery" ,python-sphinx-gallery)
("python-numpydoc" ,python-numpydoc)
("python-ipython" ,python-ipython)
@@ -4037,7 +4038,12 @@ toolkits.")
(license (package-license python-matplotlib))))
(define-public python2-matplotlib-documentation
- (package-with-python2 python-matplotlib-documentation))
+ (let ((parent (package-with-python2 python-matplotlib-documentation)))
+ (package
+ (inherit parent)
+ (native-inputs
+ (alist-delete "python-sphinx-copybutton"
+ (package-native-inputs parent))))))
(define-public python-matplotlib-venn
(package