summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimakakos Dimos <me@bendersteed.tech>2020-04-04 02:05:36 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-04 11:33:09 +0200
commit51d4587a6998af30598de153fd7ed5ca1baae6d0 (patch)
tree23790a6a471a6315ae1570938811e73dea233049
parente8a1c5af8421910d80e6bf4ecc6440e9200c76b1 (diff)
downloadpatches-51d4587a6998af30598de153fd7ed5ca1baae6d0.tar
patches-51d4587a6998af30598de153fd7ed5ca1baae6d0.tar.gz
gnu: Add emacs-modus-vivendi-theme.
* gnu/packages/emacs-xyz.scm (emacs-modus-vivendi-theme): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c0ece8b94e..9c59b72aca 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20690,6 +20690,27 @@ is cast on a light backdrop (Modus Operandi) and another where light text is
displayed against a dark background (Modus Vivendi).")
(license license:gpl3+)))
+(define-public emacs-modus-vivendi-theme
+ (package
+ (name "emacs-modus-vivendi-theme")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "modus-vivendi-theme-" version ".el"))
+ (sha256
+ (base32 "1w4vrg39dghghkvll3h4kmzykc3zpp6pbychb39gcc13z2b06v8g"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/protesilaos/modus-themes")
+ (synopsis "Accessible dark theme (WCAG AAA)")
+ (description
+ "Modus vivendi is the dark version of the Modus accessible themes for GNU
+Emacs. The contrast ratio between foreground and background values should
+always be greater than 7:1, which conforms with the WCAG AAA accessibility
+standard. This is the highest standard of its kind.")
+ (license license:gpl3+)))
+
(define-public emacs-punpun-theme
(let ((commit "2f78125609277b2478abdebd8f9d5ee10a823b65")
(revision "0"))