summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-04-04 21:50:22 +0100
committerGuix Patches Tester <>2020-04-04 22:16:06 +0100
commit3fd3d2ae501b159e58dc19d6f679a1bde01c3ddd (patch)
treec95ca1b08c6a3a32ab53a5474abbec6db013f83d
parent4719b715726303d680cd6f65caad96bfa194cda6 (diff)
downloadpatches-3fd3d2ae501b159e58dc19d6f679a1bde01c3ddd.tar
patches-3fd3d2ae501b159e58dc19d6f679a1bde01c3ddd.tar.gz
gnu: Add libuv-static.
* gnu/packages/libevent.scm (libuv-static): New variable.
-rw-r--r--gnu/packages/libevent.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 3754a5c427..a0534a97d5 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -178,6 +178,14 @@ and Prima). It also comes with a very fast Pure Perl event loop that does
not rely on XS.")
(license perl-license)))
+(define-public libuv-static
+ (package/inherit libuv
+ (arguments
+ '(#:tests? #f
+ #:make-flags (list "CFLAGS=-fPIC")))
+ ;; This version is needed by zynfusion
+ (version "1.9.1")))
+
(define-public perl-ev
(package
(name "perl-ev")