summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Gesthuizen <tim.gesthuizen@yahoo.de>2019-09-09 18:48:31 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-12 23:22:19 +0200
commit2151e04c1acf48c3fb4ec5a2703a9a88f2323d2e (patch)
treee0c86e5e56f13861ac09fcf3490452f14f40a5e6
parentd236cd16a7173278ca69578d3e7ce4d1ce55e04c (diff)
downloadpatches-2151e04c1acf48c3fb4ec5a2703a9a88f2323d2e.tar
patches-2151e04c1acf48c3fb4ec5a2703a9a88f2323d2e.tar.gz
gnu: Add emacs-doom-themes.
* gnu/packages/emacs-xyz.scm (emacs-doom-themes): New variable. Co-authored-by: Brett Gilio <brettg@posteo.net> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b5a20680ab..3c63663263 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18199,3 +18199,37 @@ You can customize: @code{tao-theme-scale-fn}, that returns 16 2-digit numbers;
@code{tao-theme-scale-filter-fn}, for edge filter; and
@code{tao-theme-use-height}.")
(license license:gpl3+))))
+
+(define-public emacs-doom-themes
+ (package
+ (name "emacs-doom-themes")
+ (version "2.1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hlissner/emacs-doom-themes.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "042pzcdhxi2z07jcscgjbaki9nrrm0cbgbbrnymd1r4q8ckkn8l9"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("emacs-ert-runner" ,emacs-ert-runner)))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'move-themes
+ (lambda _
+ ;; Move the source files to the top level, which is in the
+ ;; EMACSLOADPATH.
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ (find-files "./themes" ".*\\.el$"))
+ #t)))))
+ (synopsis "Wide collection of color themes for Emacs")
+ (description "Emacs-doom-themes contains numerous popular color themes for
+Emacs that integrate with major modes like Org-mode.")
+ (home-page "https://github.com/hlissner/emacs-doom-themes")
+ (license license:expat)))