summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-04-03 16:08:03 -0700
committerVagrant Cascadian <vagrant@debian.org>2020-04-03 16:08:03 -0700
commit1b131e1f5a8a7f5ffa9c52ced65bd4472d736d26 (patch)
tree785e9433730983b382c7ab6beb0f848b8bf50053
parent41a795e726855de140526a2f0cd2b1b94bddc10b (diff)
downloadpatches-1b131e1f5a8a7f5ffa9c52ced65bd4472d736d26.tar
patches-1b131e1f5a8a7f5ffa9c52ced65bd4472d736d26.tar.gz
gnu: Add linux-libre 5.6.2.
* gnu/packages/linux (deblob-scripts-5.6): New variable. (linux-libre-5.6-version): New variable. (linux-libre-5.6-pristine-source): New variable. (linux-libre-5.6-source): New variable. (linux-libre-headers-5.6): New variable. (linux-libre-5.6): New variable.
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fc3759bd96..f71cc93843 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -192,6 +192,12 @@ defconfig. Return the appropriate make target if applicable, otherwise return
"deblob-check"))
(sha256 deblob-check-hash))))
+(define deblob-scripts-5.6
+ (linux-libre-deblob-scripts
+ "5.6"
+ (base32 "09hxrr4xzllq5lmipfb6if30318lksrk9py1axc36m9ynql4w0rc")
+ (base32 "09qz5d31g5zwicsnncjnjij193hk0g6kg0ss9jyzh6lp3wilcm71")))
+
(define deblob-scripts-5.4
(linux-libre-deblob-scripts
"5.4.28"
@@ -362,6 +368,15 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
"linux-" version ".tar.xz"))
(sha256 hash)))
+
+(define-public linux-libre-5.6-version "5.6.2")
+(define-public linux-libre-5.6-pristine-source
+ (let ((version linux-libre-5.6-version)
+ (hash (base32 "1fdmcx5fk9wq9yx6vvnw76nvdysbvm83cik1dj1d67lw6bc92k9d")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-5.6)))
+
(define-public linux-libre-5.4-version "5.4.30")
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
@@ -430,6 +445,15 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-5.6-source
+ (source-with-patches linux-libre-5.6-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch
+ ;; Pinebook Pro patch from linux-next,
+ ;; can be dropped for linux-libre 5.7
+ (search-patch
+ "linux-libre-support-for-Pinebook-Pro.patch"))))
+
(define-public linux-libre-5.4-source
(source-with-patches linux-libre-5.4-pristine-source
(list %boot-logo-patch
@@ -529,6 +553,10 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-5.6
+ (make-linux-libre-headers* linux-libre-5.6-version
+ linux-libre-5.6-source))
+
(define-public linux-libre-headers-5.4
(make-linux-libre-headers* linux-libre-5.4-version
linux-libre-5.4-source))
@@ -793,6 +821,12 @@ It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-5.6
+ (make-linux-libre* linux-libre-5.6-version
+ linux-libre-5.6-source
+ '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-5.4
(make-linux-libre* linux-libre-5.4-version
linux-libre-5.4-source