summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2017-02-20 01:37:40 -0500
committerRicardo Wurmus <rekado@elephly.net>2017-10-10 23:09:41 +0200
commit0cd83b4e000df50f93f00b3b77691852afe57b7f (patch)
treed26a188aca7698d5421bf625da33ac6d6e2aa2ba
parent96cb5ca1f2418871a53c6993aae6209016681ce1 (diff)
downloadpatches-0cd83b4e000df50f93f00b3b77691852afe57b7f.tar
patches-0cd83b4e000df50f93f00b3b77691852afe57b7f.tar.gz
gnu: Add python-incremental.
* gnu/packages/python.scm (python-incremental, python2-incremental): New variables. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c9e52c9e5e..1414979378 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14228,6 +14228,27 @@ Python. It is based on Parsing Expression Grammars, PEG. With pyPEG you can
parse many formal languages.")
(license license:gpl2)))
+(define-public python-incremental
+ (package
+ (name "python-incremental")
+ (version "17.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "incremental" version))
+ (sha256
+ (base32
+ "1cylxdz1cnkm5g3pklna3h2n0i0rks95ir1pnpxfnvpkmab1cxbv"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/hawkowl/incremental")
+ (synopsis "Library for versioning Python projects")
+ (description "Incremental is a small library that versions your Python
+projects.")
+ (license license:expat)))
+
+(define-public python2-incremental
+ (package-with-python2 python-incremental))
+
(define-public python-automat
(package
(name "python-automat")