summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public12@thebird.nl>2015-09-16 05:03:48 +0200
committerDavid Thompson <dthompson2@worcester.edu>2015-09-16 20:56:16 -0400
commitcd89fecbe71a1f72c676eb0589d218237ccbf43b (patch)
treeaf8cee6e3b7f9a0096aa3f2fab25e3915fa98a12
parenta8be7b9a7a73abdd9bf91a989dc10865800a0270 (diff)
downloadpatches-cd89fecbe71a1f72c676eb0589d218237ccbf43b.tar
patches-cd89fecbe71a1f72c676eb0589d218237ccbf43b.tar.gz
gnu: Add ruby-cucumber-core.
* gnu/packages/ruby.scm (ruby-cucumber-core): New variable.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e61332f6aa..a4702289c9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1171,3 +1171,30 @@ It is intended to replace Gherkin 2 and be used by all Cucumber
implementations to parse '.feature' files.")
(home-page "https://github.com/cucumber/gherkin3")
(license license:expat)))
+
+(define-public ruby-cucumber-core
+ (package
+ (name "ruby-cucumber-core")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "cucumber-core" version))
+ (sha256
+ (base32
+ "12mrzf0s96izpq0k10lahlkgwc4fjs0zfs344rh8r8h3w3jyppr8"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-gherkin3" ,ruby-gherkin3)))
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (arguments
+ '(#:tests? #f)) ; needs simplecov, among others
+ (synopsis "Core library for the Cucumber BDD app")
+ (description "Cucumber is a tool for running automated tests
+written in plain language. Because they're written in plain language,
+they can be read by anyone on your team. Because they can be read by
+anyone, you can use them to help improve communication, collaboration
+and trust on your team.")
+ (home-page "https://cucumber.io/")
+ (license license:expat)))