summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-03 14:39:49 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-03 16:26:37 +0200
commitc627e2cba43e5b11721f951689cf4cf19e263a59 (patch)
tree6037360158074084d3c7a23cf27ac6107dd159e0
parent1ace39da78dc076f60542ad7729a29f2f6760076 (diff)
downloadpatches-c627e2cba43e5b11721f951689cf4cf19e263a59.tar
patches-c627e2cba43e5b11721f951689cf4cf19e263a59.tar.gz
gnu: gnome-initial-setup: Record file name of 'gsd-keyboard-display'.
* gnu/packages/gnome.scm (gnome-initial-setup)[arguments]: Add 'set-gkbd-file-name' phase. [inputs]: Add LIBGNOMEKBD.
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 15b5d91a0f..656ea6f904 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -536,7 +536,18 @@ extraction, and lookup for applications on the desktop.")
(arguments
'(#:configure-flags '(;; Enable camera support for user selfie.
"-Dcheese=auto"
- "-Dsystemd=false")))
+ "-Dsystemd=false")
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'set-gkbd-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Allow the "Preview" button in the keyboard layout
+ ;; selection dialog to display the layout.
+ (let ((libgnomekbd (assoc-ref inputs "libgnomekbd")))
+ (substitute* "gnome-initial-setup/pages/keyboard/cc-input-chooser.c"
+ (("\"gkbd-keyboard-display")
+ (string-append "\"" libgnomekbd
+ "/bin/gkbd-keyboard-display")))
+ #t))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
@@ -565,7 +576,8 @@ extraction, and lookup for applications on the desktop.")
("pwquality" ,libpwquality)
("rest" ,rest)
("upower" ,upower)
- ("webkitgtk" ,webkitgtk)))
+ ("webkitgtk" ,webkitgtk)
+ ("libgnomekbd" ,libgnomekbd)))
(synopsis "Initial setup wizard for GNOME desktop")
(description "This package provides a set-up wizard when a
user logs into GNOME for the first time. It typically provides a