summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-02 23:13:20 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-03 15:55:41 +0100
commitb4a003f63565e3b3db65593468348da40e811521 (patch)
tree56c69864a4da4e56405e51799699653e135896d0
parentce3e95d78e6e76e6ab2d83204cf7c34286ab210c (diff)
downloadpatches-b4a003f63565e3b3db65593468348da40e811521.tar
patches-b4a003f63565e3b3db65593468348da40e811521.tar.gz
gnu: Add perl-data-float.
* gnu/packages/perl.scm (perl-data-float): New variable.
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6adde83996..d0583e1997 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2098,6 +2098,34 @@ statement. It handles self-referential structures correctly.")
indentation and newlines plus sub deparsing.")
(license (package-license perl))))
+(define-public perl-data-float
+ (package
+ (name "perl-data-float")
+ (version "0.013")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/Z/ZE/ZEFRAM/Data-Float-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12ji4yf3nc965rqqgfhr96w7irpm6n1g15nivfxvhc49hlym5cg2"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (home-page "https://metacpan.org/release/Data-Float")
+ (synopsis "Details of the floating point data type")
+ (description "@code{Data::Float} is about the native floating
+point numerical data type. A floating point number is one of the
+types of datum that can appear in the numeric part of a Perl scalar.
+This module supplies constants describing the native floating point
+type, classification functions and functions to manipulate floating
+point values at a low level.")
+ (license perl-license)))
+
(define-public perl-data-optlist
(package
(name "perl-data-optlist")