summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-03 11:16:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-03 11:25:17 -0400
commit22a49c09eed46cd7b09ef1c557aadb63ed45b8fb (patch)
tree119ddf9738465c8d8a5a422c4004c67905539b92
parent91b3f58de83d303548017ac5bf1d9e2f86f38a6a (diff)
downloadpatches-22a49c09eed46cd7b09ef1c557aadb63ed45b8fb.tar
patches-22a49c09eed46cd7b09ef1c557aadb63ed45b8fb.tar.gz
gnu: Add python-bitstruct.
* gnu/packages/python-xyz.scm (python-bitstruct): New variable.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0bdf165119..cd431e401f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1227,6 +1227,26 @@ sending and receiving messages on a CAN bus.")
(description "DiskCache is a disk and file backed persistent cache.")
(license license:asl2.0)))
+(define-public python-bitstruct
+ (package
+ (name "python-bitstruct")
+ (version "8.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bitstruct" version))
+ (sha256
+ (base32
+ "1fpc1qh1vss05ap29xvhjp200fm0q4pvgcjl0qpryh7ay6xgr5vx"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/eerimoq/bitstruct")
+ (synopsis "Python values to and C bit field structs converter")
+ (description "This module performs conversions between Python values and C
+bit field structs represented as Python byte strings. It is intended to have
+a similar interface as the @code{struct} module from Python, but working on
+bits instead of primitive data types like @code{char}, @code{int}, etc.")
+ (license license:expat)))
+
(define-public python-capturer
(package
(name "python-capturer")