summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-01 18:54:53 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-03 13:01:07 +0200
commit13f401d3665a246f5e7d3a9076fdedfe744dd3fd (patch)
tree99595512e6cdc294c33b85b31ae05bb13bfbad48
parent02d5d72cfc525e1ec53a02f3a201872f261c7c37 (diff)
downloadpatches-13f401d3665a246f5e7d3a9076fdedfe744dd3fd.tar
patches-13f401d3665a246f5e7d3a9076fdedfe744dd3fd.tar.gz
gnu: Add ortp.
* gnu/packages/linphone.scm (ortp): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/linphone.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 97aed42a36..705790b894 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -20,6 +20,8 @@
(define-module (gnu packages linphone)
#:use-module (gnu packages)
#:use-module (gnu packages base)
+ #:use-module (gnu packages documentation)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages tls)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -190,3 +192,32 @@ supports concurrent channels encoding and decoding for multi call application
such as conferencing.")
(home-page "https://gitlab.linphone.org/BC/public/belcard")
(license license:gpl2+)))
+
+(define-public ortp
+ (package
+ (name "ortp")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://www.linphone.org/releases/sources/" name
+ "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "016qg0lmdgmqh2kv19w9qhi4kkiyi5h1xp35g2s65b1j8ccm25d5"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test target
+ #:configure-flags
+ (list
+ "-DENABLE_STATIC=NO"))) ; Not required
+ (native-inputs
+ `(("dot" ,graphviz)
+ ("doxygen" ,doxygen)))
+ (inputs
+ `(("bctoolbox" ,bctoolbox)))
+ (synopsis "Belledonne Communications RTP Library")
+ (description "oRTP is a C library implementing the RTP protocol. It
+implements the RFC 3550 standard.")
+ (home-page "https://gitlab.linphone.org/BC/public/ortp")
+ (license license:gpl2+)))