summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-01 18:44:35 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-03 13:01:07 +0200
commit02d5d72cfc525e1ec53a02f3a201872f261c7c37 (patch)
tree58644d0d9b429131c99e0f83d892be54130fc542
parent73bfb14f8ff105bbc8a8836f475f72867297fe93 (diff)
downloadpatches-02d5d72cfc525e1ec53a02f3a201872f261c7c37.tar
patches-02d5d72cfc525e1ec53a02f3a201872f261c7c37.tar.gz
gnu: Add bcg729.
* gnu/packages/linphone.scm (bcg729): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/linphone.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index cf5c807669..97aed42a36 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -163,3 +163,30 @@ picture, or subtitle tracks in one file. ")
;; That license applies for LibMatroska2.
;; https://www.matroska.org/node/47
license:lgpl2.1+))))
+
+(define-public bcg729
+ (package
+ (name "bcg729")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://www.linphone.org/releases/sources/" name
+ "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "01y34ky7ykjgfnf8a9f59hg61fqfjiprfrzshdz06w0lz4gvy3qs"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test target
+ #:configure-flags
+ (list
+ "-DENABLE_STATIC=NO"))) ; Not required
+ (synopsis "Belledonne Communications G729 Codec")
+ (description "BcG729 is an implementation of both encoder and decoder of
+the ITU G729 speech codec. The library written in C 99 is fully portable and
+can be executed on many platforms including both ARM and x86 processors. It
+supports concurrent channels encoding and decoding for multi call application
+such as conferencing.")
+ (home-page "https://gitlab.linphone.org/BC/public/belcard")
+ (license license:gpl2+)))