summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-01 18:30:24 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-03 12:43:18 +0200
commitc8f69ec27b4d492f63edc71f0a83ec413ea85b96 (patch)
tree329e5854b8f83e5e6d4cdcf521fd8f95460cd7ca
parent63c73bcad0ccd44363611162010b24e2b60629f4 (diff)
downloadpatches-c8f69ec27b4d492f63edc71f0a83ec413ea85b96.tar
patches-c8f69ec27b4d492f63edc71f0a83ec413ea85b96.tar.gz
gnu: Add belcard.
* gnu/packages/linphone.scm (belcard): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/linphone.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 862b2fc8f9..c95f44afe4 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -105,3 +105,29 @@ written in C++11. It parses text inputs formatted according to a language
defined by an ABNF grammar, such as the protocols standardized at IETF.")
(home-page "https://gitlab.linphone.org/BC/public/belr")
(license license:gpl3+)))
+
+(define-public belcard
+ (package
+ (name "belcard")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://www.linphone.org/releases/sources/" name
+ "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0iiyrll1shnbb0561pkvdqcmx9b2cdr76xpsbaqdirc3s4xzcl0k"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test target
+ #:configure-flags
+ (list
+ "-DENABLE_STATIC=OFF"))) ; Not required
+ (inputs
+ `(("bctoolbox" ,bctoolbox)
+ ("belr" ,belr)))
+ (synopsis "Belledonne Communications VCard Library")
+ (description "Belcard is a C++ library to manipulate VCard standard format.")
+ (home-page "https://gitlab.linphone.org/BC/public/belcard")
+ (license license:gpl3+)))