summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-01 18:38:01 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-03 12:45:28 +0200
commit28f6f1e0da2481ce854a893d72d6bdfc5ce97952 (patch)
tree9bbeb3d36e4dc6eec9510aa7c45478cfce26e4d4
parentc8f69ec27b4d492f63edc71f0a83ec413ea85b96 (diff)
downloadpatches-28f6f1e0da2481ce854a893d72d6bdfc5ce97952.tar
patches-28f6f1e0da2481ce854a893d72d6bdfc5ce97952.tar.gz
gnu: Add bcmatroska2.
* gnu/packages/linphone.scm (bcmatroska2): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/linphone.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index c95f44afe4..cf5c807669 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -131,3 +131,35 @@ defined by an ABNF grammar, such as the protocols standardized at IETF.")
(description "Belcard is a C++ library to manipulate VCard standard format.")
(home-page "https://gitlab.linphone.org/BC/public/belcard")
(license license:gpl3+)))
+
+(define-public bcmatroska2
+ (package
+ (name "bcmatroska2")
+ (version "0.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://www.linphone.org/releases/sources/" name
+ "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1a0vlk4fhh189pfzrwbc3xbc5vyx6cnxy642d1h40045jz9y4h15"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test target
+ #:configure-flags
+ (list
+ "-DENABLE_STATIC=NO"))) ; Not required
+ (synopsis "Belledonne Communications Media Container")
+ (description "BcMatroska is a free and open standard multi-media
+container format. It can hold an unlimited number of video, audio,
+picture, or subtitle tracks in one file. ")
+ (home-page "https://gitlab.linphone.org/BC/public/bcmatroska2")
+ (license
+ (list
+ ;; That license applies for Core C and LibEBML2.
+ ;; https://www.matroska.org/node/47
+ license:bsd-4
+ ;; That license applies for LibMatroska2.
+ ;; https://www.matroska.org/node/47
+ license:lgpl2.1+))))