summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-03-28 10:30:48 -0700
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:14 +0200
commitbe41d7d91df123a454e871190f1bb2711409bfa8 (patch)
tree869ef726c3274c41b319de3f6c3864d624ae4692
parenta8f1b52017820c87b9bb38abb42b48d8059688d3 (diff)
downloadpatches-be41d7d91df123a454e871190f1bb2711409bfa8.tar
patches-be41d7d91df123a454e871190f1bb2711409bfa8.tar.gz
gnu: cedille: Install the info pages.
* gnu/packages/cedille.scm (cedille)[arguments]: Rename phase 'patch-cedille-path-el' to 'patch-cedille-paths' and add substitution for the info page location. In the 'copy-cedille-mode' phase, install the info page. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/cedille.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/cedille.scm b/gnu/packages/cedille.scm
index 9f6c01ea80..d3dd576323 100644
--- a/gnu/packages/cedille.scm
+++ b/gnu/packages/cedille.scm
@@ -51,15 +51,19 @@
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-cedille-path-el
+ (add-after 'unpack 'patch-cedille-paths
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(substitute* "cedille-mode.el"
(("/usr/share/emacs/site-lisp/cedille-mode")
(string-append
out "/share/emacs/site-lisp/cedille")))
+ (substitute* "cedille-mode/cedille-mode-info.el"
+ (("\\(concat cedille-path-el \"cedille-info-main.info\"\\)")
+ (string-append
+ "\"" out "/share/info/cedille-info-main.info.gz\"")))
#t)))
- (add-after 'unpack 'copy-cedille-mode
+ (add-after 'patch-cedille-paths 'copy-cedille-mode
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(lisp
@@ -107,6 +111,8 @@
(install-file "cedille" (string-append out "/bin"))
(install-file "core/cedille-core"
(string-append out "/bin"))
+ (install-file "docs/info/cedille-info-main.info"
+ (string-append out "/share/info"))
#t))))))
(home-page "https://cedille.github.io/")
(synopsis