summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2020-03-24 19:49:10 -0500
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:16 +0200
commitbdbe69f6596aeff4cba76ba40b7afffb1b106ca0 (patch)
tree58c9e112083a0eab6e82498928ce79e8a37ad7b4
parentacbba42d5686bfe73905f47ef3038520b82f36ac (diff)
downloadpatches-bdbe69f6596aeff4cba76ba40b7afffb1b106ca0.tar
patches-bdbe69f6596aeff4cba76ba40b7afffb1b106ca0.tar.gz
gnu: Add python-pem.
* gnu/packages/python-xyz.scm: (python-pem) New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e01e115e92..901b241a24 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19017,3 +19017,29 @@ actions: actions can spawn other actions, and eventually they either succeed
or fail. The resulting logs tell you the story of what your software did: what
happened, and what caused it.")
(license license:asl2.0)))
+
+(define-public python-pem
+ (package
+ (name "python-pem")
+ (version "20.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pem" version))
+ (sha256
+ (base32
+ "1xh88ss279fprxnzd10dczmqwjhppbyvljm33zrg2mgybwd66qr7"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-certifi" ,python-certifi)
+ ("python-coverage" ,python-coverage)
+ ("python-pretend" ,python-pretend)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-pytest" ,python-pytest)
+ ("python-sphinx" ,python-sphinx)
+ ("python-twisted" ,python-twisted)))
+ (home-page "https://pem.readthedocs.io/")
+ (synopsis "Easy PEM file parsing in Python")
+ (description
+ "This package provides a Python module for parsing and splitting PEM files.")
+ (license license:expat)))