summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2020-02-29 11:07:34 -0600
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:15 +0200
commitbc834c0f625dfe77e430f23c5a316129bbca5d9a (patch)
treecb44f4e4777069c1abcdccaee109d330366ed984
parent3094c0ae59ef99644cda79b6077073651847b726 (diff)
downloadpatches-bc834c0f625dfe77e430f23c5a316129bbca5d9a.tar
patches-bc834c0f625dfe77e430f23c5a316129bbca5d9a.tar.gz
gnu: Add python-unpaddedbase64.
* gnu/packages/python-xyz.scm (python-unpaddedbase64): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 24c449f028..03f6b63e2b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18746,3 +18746,26 @@ dumping of JSON5 data structures.")
implements the complete mapping interface. It can be used as a drop-in
replacement for dictionaries where immutability is desired.")
(license license:expat)))
+
+(define-public python-unpaddedbase64
+ (package
+ (name "python-unpaddedbase64")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/matrix-org/python-unpaddedbase64.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0if3fjfxga0bwdq47v77fs9hrcqpmwdxry2i2a7pdqsp95258nxd"))))
+ (build-system python-build-system)
+ (home-page "https://pypi.org/project/unpaddedbase64/")
+ (synopsis "Encode and decode Base64 without “=” padding")
+ (description
+ "RFC 4648 specifies that Base64 should be padded to a multiple of 4 bytes
+using “=” characters. However this conveys no benefit so many protocols
+choose to use Base64 without the “=” padding.")
+ (license license:asl2.0)))