summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-03-24 15:10:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:13 +0200
commit9d4ed3570395a6e898ade698186a5f9cd23097cc (patch)
tree34ada2f387f6722e568319641f79900f59c7a398
parent3ccfa4048a005c762d7d4b0f2d143714032a1ba9 (diff)
downloadpatches-9d4ed3570395a6e898ade698186a5f9cd23097cc.tar
patches-9d4ed3570395a6e898ade698186a5f9cd23097cc.tar.gz
gnu: sdl2: Use udev to discover input devices.
Without udev SDL falls back on custom detection code, which blocks every three seconds while checking for new devices. * gnu/packages/sdl.scm (sdl2)[inputs]: Add eudev. [arguments]<#:make-flags>: Add LDFLAGS to include eudev in rpath so that dlopen can find it. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/sdl.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 25b0bdba2b..8b21f813c9 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -132,20 +132,26 @@ joystick, and graphics hardware.")
"--disable-kmsdrm-shared")
,flags))
((#:make-flags flags ''())
- ;; Add the Fcitx header files to GCCs "system header" search path
- ;; in order to suppress compiler warnings induced by those:
- ;; .../include/fcitx-utils/utarray.h:178:9: error: ISO C90 forbids
- ;; mixed declarations and code [-Werror=declaration-after-statement]
- `(append (list (string-append "C_INCLUDE_PATH="
- (assoc-ref %build-inputs "fcitx")
- "/include"))
- ,flags))))
+ `(cons*
+ ;; Add the Fcitx header files to GCCs "system header" search path
+ ;; in order to suppress compiler warnings induced by those:
+ ;; .../include/fcitx-utils/utarray.h:178:9: error: ISO C90 forbids
+ ;; mixed declarations and code [-Werror=declaration-after-statement]
+ (string-append "C_INCLUDE_PATH="
+ (assoc-ref %build-inputs "fcitx") "/include")
+ ;; SDL dlopens libudev, so make sure it is in rpath. This overrides
+ ;; the LDFLAG set in sdl’s configure-flags, which isn’t necessary
+ ;; as sdl2 includes Mesa by default.
+ (string-append "LDFLAGS=-Wl,-rpath,"
+ (assoc-ref %build-inputs "eudev") "/lib")
+ ,flags))))
(inputs
;; SDL2 needs to be built with ibus support otherwise some systems
;; experience a bug where input events are doubled.
;;
;; For more information, see: https://dev.solus-project.com/T1721
(append `(("dbus" ,dbus)
+ ("eudev" ,eudev) ; for discovering input devices
("fcitx" ,fcitx) ; helps with CJK input
("glib" ,glib)
("ibus" ,ibus)