summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-02 15:32:38 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-02 16:07:12 +0200
commit8a5cdc078c17d3789e156b259d6b3a8335cc9a7b (patch)
treef9ce36641f2d2c2a9850a0deccbccc22561117bb
parentae8e0fbd82ca8406dc55aa1f55c4681331e0d215 (diff)
downloadpatches-8a5cdc078c17d3789e156b259d6b3a8335cc9a7b.tar
patches-8a5cdc078c17d3789e156b259d6b3a8335cc9a7b.tar.gz
gnu: mate-control-center: Fix file name in polkit rule.
* gnu/packages/mate.scm (mate-control-center)[arguments]: New field.
-rw-r--r--gnu/packages/mate.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 6a0d024263..28f6b1e76f 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
@@ -959,6 +959,19 @@ icons on the MATE desktop. It works on local and remote file systems.")
(base32
"192plsh83m2qz7jgakns2yvhqbj53v7i54iwb0z26i2awy0j9rcd"))))
(build-system glib-or-gtk-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'build 'fix-polkit-action
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure the polkit file refers to the right
+ ;; executable.
+ (let ((out (assoc-ref outputs "out")))
+ (substitute*
+ '("capplets/display/org.mate.randr.policy.in"
+ "capplets/display/org.mate.randr.policy")
+ (("/usr/sbin")
+ (string-append out "/sbin")))
+ #t))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)