summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2020-02-29 11:12:08 -0600
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:16 +0200
commit858f3834be5b534fb08d237d393e3ccb7a1d31f2 (patch)
tree00bcc31adacd3b5b2debd938017050be5cb53ef1
parent534fadf91db7e837c72943664c55418eddc37ffd (diff)
downloadpatches-858f3834be5b534fb08d237d393e3ccb7a1d31f2.tar
patches-858f3834be5b534fb08d237d393e3ccb7a1d31f2.tar.gz
gnu: Add python-ldap3.
* gnu/packages/python-xyz.scm (python-ldap3): New variable. Co-authored-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a424cd0f58..d148f167f4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18900,3 +18900,36 @@ enforcement of that policy.")
(description
"This is the official Python client for the Prometheus monitoring server.")
(license license:asl2.0)))
+
+(define-public python-ldap3
+ (package
+ (name "python-ldap3")
+ (version "2.7")
+ (home-page "https://github.com/cannatag/ldap3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xw9fkqld21xsvdpaqir8ccc2l805xnn9gxahsnl70xzp3mwl0xv"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f ;TODO: Tests need a real LDAP server to run
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "nosetests" "-s" "test"))
+ #t)))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-gssapi" ,python-gssapi)
+ ("python-pyasn1" ,python-pyasn1)))
+ (synopsis "Python LDAP client")
+ (description
+ "LDAP3 is a strictly RFC 4510 conforming LDAP V3 pure Python client
+library.")
+ (license license:lgpl3+)))