summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-03-27 08:31:10 -0700
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:14 +0200
commit79e5d150c637d56df80c8b69d35941f4798217ae (patch)
tree727c8c3f63ebb7861946ca5c1180de18c4e63e3b
parentbe41d7d91df123a454e871190f1bb2711409bfa8 (diff)
downloadpatches-79e5d150c637d56df80c8b69d35941f4798217ae.tar
patches-79e5d150c637d56df80c8b69d35941f4798217ae.tar.gz
gnu: Add xwallpaper.
* gnu/packages/xdisorg.scm (xwallpaper): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/xdisorg.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 22c8adc6fa..13ac124ca1 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2020 Ivan Vilata i Balaguer <ivan@selidor.net>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Damien Cassou <damien@cassou.me>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2019,6 +2020,42 @@ can optionally use some appearance settings from XSettings, tint2 and GTK.")
(home-page "https://jgmenu.github.io/")
(license license:gpl2)))
+(define-public xwallpaper
+ (package
+ (name "xwallpaper")
+ (version "0.6.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stoeckmann/xwallpaper")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "175fzifvia58vah2x7509drvfn3xfv5d9szgh9x1w1a1w8rcs2hx"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libjpeg-turbo" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("libxpm" ,libxpm)
+ ("pixman" ,pixman)
+ ("xcb-util" ,xcb-util)
+ ("xcb-util-image" ,xcb-util-image)))
+ (home-page "https://github.com/stoeckmann/xwallpaper")
+ (synopsis "Wallpaper setting utility for X")
+ (description
+ "The xwallpaper utility allows you to set image files as your X
+wallpaper. JPEG, PNG, and XPM file formats are supported.
+
+The wallpaper is also advertised to programs which support semi-transparent
+backgrounds.")
+ (license license:isc)))
+
(define-public xwrits
(package
(name "xwrits")