summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-03-29 02:18:56 -0700
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:14 +0200
commit5bd5d6ef2d42367398176aea87fe6a1fe61ab198 (patch)
tree4b838fbfc6e83970b19db8582bcc3ba21f7079b4
parenta6ac679f0a5556ad301e6f59755ec1886833ba82 (diff)
downloadpatches-5bd5d6ef2d42367398176aea87fe6a1fe61ab198.tar
patches-5bd5d6ef2d42367398176aea87fe6a1fe61ab198.tar.gz
gnu: proof-general: Update to 4.4.
* gnu/packages/coq.scm (proof-general): Update to 4.4. [source]: Change to GIT-FETCH. [arguments]: Remove obsolete substitutions. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/coq.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index f883c2f690..2ff31c5f39 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -132,15 +132,17 @@ It is developed using Objective Caml and Camlp5.")
(define-public proof-general
(package
(name "proof-general")
- (version "4.2")
+ (version "4.4")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://proofgeneral.inf.ed.ac.uk/releases/"
- "ProofGeneral-" version ".tgz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append
+ "https://github.com/ProofGeneral/PG"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "09qb0myq66fw17v4ziz401ilsb5xlxz1nl2wsp69d0vrfy0bcrrm"))))
+ "0bdfk91wf71z80mdfnl8hpinripndcjgdkz854zil6521r84nqk8"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)
@@ -175,10 +177,6 @@ It is developed using Objective Caml and Camlp5.")
(emacs (assoc-ref inputs "host-emacs")))
(define (coq-prog name)
(string-append coq "/bin/" name))
- (emacs-substitute-variables "coq/coq.el"
- ("coq-prog-name" (coq-prog "coqtop"))
- ("coq-compiler" (coq-prog "coqc"))
- ("coq-dependency-analyzer" (coq-prog "coqdep")))
(substitute* "Makefile"
(("/sbin/install-info") "install-info"))
(substitute* "bin/proofgeneral"