summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2020-02-29 11:11:35 -0600
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:15 +0200
commit534fadf91db7e837c72943664c55418eddc37ffd (patch)
tree92b2f4a347e381e3e5588eaaae9a6aa0ce7c6390
parent4fd0a4a4e9989cf8bc428a838e84f85b14202856 (diff)
downloadpatches-534fadf91db7e837c72943664c55418eddc37ffd.tar
patches-534fadf91db7e837c72943664c55418eddc37ffd.tar.gz
gnu: Add python-prometheus-client.
* gnu/packages/python-xyz.scm (python-prometheus-client): New variable. Co-authored-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9f5a53c995..a424cd0f58 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18878,3 +18878,25 @@ Macaroons allow for delegation and attenuation of authorization. They are
simple and fast to verify, and decouple authorization policy from the
enforcement of that policy.")
(license license:expat)))
+
+(define-public python-prometheus-client
+ (package
+ (name "python-prometheus-client")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "prometheus_client" version))
+ (sha256
+ (base32 "1ni2yv4ixwz32nz39ckia76lvggi7m19y5f702w5qczbnfi29kbi"))))
+ (build-system python-build-system)
+ (arguments
+ ;; TODO: No tests in the PyPI distribution.
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-twisted" ,python-twisted)))
+ (home-page "https://github.com/prometheus/client_python")
+ (synopsis "Prometheus instrumentation library")
+ (description
+ "This is the official Python client for the Prometheus monitoring server.")
+ (license license:asl2.0)))