summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2020-02-29 11:11:11 -0600
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:15 +0200
commit4fd0a4a4e9989cf8bc428a838e84f85b14202856 (patch)
treeffe868c667c5288e840b05234cedb9fe517e4b10
parent039c5499002bfc2294927bfd7c8c7f3b08cfce2c (diff)
downloadpatches-4fd0a4a4e9989cf8bc428a838e84f85b14202856.tar
patches-4fd0a4a4e9989cf8bc428a838e84f85b14202856.tar.gz
gnu: Add python-pymacaroons.
* gnu/packages/python-xyz.scm (python-pymacaroons): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b37294fcf0..9f5a53c995 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18851,3 +18851,30 @@ key.
(synopsis "Library for writing system daemons in Python")
(description "Daemonize is a library for writing system daemons in Python.")
(license license:expat)))
+
+(define-public python-pymacaroons
+ (package
+ (name "python-pymacaroons")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pymacaroons" version))
+ (sha256
+ (base32 "1f0357a6g1h96sk6wy030xmc1p4rd80a999qvxd28v7nlm1blsqy"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-pynacl" ,python-pynacl)))
+ (home-page "https://github.com/ecordell/pymacaroons")
+ (synopsis "Python Macaroon Library")
+ (description
+ "Macaroons, like cookies, are a form of bearer credential. Unlike opaque
+tokens, macaroons embed caveats that define specific authorization
+requirements for the target service, the service that issued the root macaroon
+and which is capable of verifying the integrity of macaroons it receives.
+
+Macaroons allow for delegation and attenuation of authorization. They are
+simple and fast to verify, and decouple authorization policy from the
+enforcement of that policy.")
+ (license license:expat)))