summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2020-02-29 11:06:27 -0600
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:15 +0200
commit3094c0ae59ef99644cda79b6077073651847b726 (patch)
treeb5d2192f03e08ae32c533b976620c6361ded8d9c
parent83670e02bc1be9481a6957a8cdb977f35a0ac483 (diff)
downloadpatches-3094c0ae59ef99644cda79b6077073651847b726.tar
patches-3094c0ae59ef99644cda79b6077073651847b726.tar.gz
gnu: Add python-frozendict.
* gnu/packages/python-xyz.scm (python-frozendict): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bee9d7d292..24c449f028 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -74,6 +74,7 @@
;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
+;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18726,3 +18727,22 @@ HTML-containing files.")
usable as a configuration language. This Python package implements parsing and
dumping of JSON5 data structures.")
(license license:asl2.0)))
+
+(define-public python-frozendict
+ (package
+ (name "python-frozendict")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "frozendict" version))
+ (sha256
+ (base32 "0ibf1wipidz57giy53dh7mh68f2hz38x8f4wdq88mvxj5pr7jhbp"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/slezica/python-frozendict")
+ (synopsis "Simple immutable mapping for Python")
+ (description
+ "@dfn{frozendict} is an immutable wrapper around dictionaries that
+implements the complete mapping interface. It can be used as a drop-in
+replacement for dictionaries where immutability is desired.")
+ (license license:expat)))