summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2020-03-24 19:38:36 -0500
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:16 +0200
commit276ddb02b5c59c2b819e306e4d592c5674bef453 (patch)
tree26e6dac200b957ba3d2918850e492bdec7765d3e
parent9a3d361b5d7d538bfe99bbe3075b8812f7e32032 (diff)
downloadpatches-276ddb02b5c59c2b819e306e4d592c5674bef453.tar
patches-276ddb02b5c59c2b819e306e4d592c5674bef453.tar.gz
gnu: Add python-pysaml2.
* gnu/packages/python-xyz.scm: (python-pysaml2) New variable. Co-authored-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 01c0e54e2b..d19adf11c5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19112,3 +19112,34 @@ Certificate Authority.
txacme is an implementation of the protocol for Twisted, the event-driven
networking engine for Python.")
(license license:expat)))
+
+(define-public python-pysaml2
+ (package
+ (name "python-pysaml2")
+ (version "5.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pysaml2" version))
+ (sha256
+ (base32
+ "1h8cmxh9cvxhrdfmkh92wg6zpxmhi2fixq1cy4hxismmaar7bsny"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-dateutil" ,python-dateutil)
+ ("python-defusedxml" ,python-defusedxml)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-pytz" ,python-pytz)
+ ("python-requests" ,python-requests)
+ ("python-six" ,python-six)))
+ (home-page "https://idpy.org")
+ (synopsis "Python implementation of SAML Version 2 Standard")
+ (description
+ "PySAML2 is a pure python implementation of SAML Version 2 Standard.
+It contains all necessary pieces for building a SAML2 service provider or
+an identity provider. The distribution contains examples of both.
+
+This package was originally written to work in a WSGI environment, but
+there are extensions that allow you to use it with other frameworks.")
+ (license license:asl2.0)))