summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2020-03-24 19:32:46 -0500
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:16 +0200
commit09e6675dadad1c8376feebf8fe67e17ac75c8ae5 (patch)
treed56a9f0a3da6cb04442053e4c5f8f8c6bf5b4a7b
parent858f3834be5b534fb08d237d393e3ccb7a1d31f2 (diff)
downloadpatches-09e6675dadad1c8376feebf8fe67e17ac75c8ae5.tar
patches-09e6675dadad1c8376feebf8fe67e17ac75c8ae5.tar.gz
gnu: Add python-boltons.
* gnu/packages/python-xyz.scm: (python-boltons) New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d148f167f4..d8647b7278 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18933,3 +18933,34 @@ enforcement of that policy.")
"LDAP3 is a strictly RFC 4510 conforming LDAP V3 pure Python client
library.")
(license license:lgpl3+)))
+
+(define-public python-boltons
+ (package
+ (name "python-boltons")
+ (version "20.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "boltons" version))
+ (sha256
+ (base32
+ "0lrr40qqj3ch8xarvyzbnbjs79pz5aywklllq53l347h1b8xnkg4"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/mahmoud/boltons")
+ (synopsis "Extensions to the Python standard library")
+ (description
+ "Boltons is a set of over 230 pure-Python utilities in the same spirit
+as — and yet conspicuously missing from — the standard library, including:
+
+@itemize
+@item Atomic file saving, bolted on with fileutils
+@item A highly-optimized OrderedMultiDict, in dictutils
+@item Two types of PriorityQueue, in queueutils
+@item Chunked and windowed iteration, in iterutils
+@item Recursive data structure iteration and merging, with iterutils.remap
+@item Exponential backoff functionality, including jitter, through
+iterutils.backoff
+@item A full-featured TracebackInfo type, for representing stack traces, in
+tbutils
+@end itemize")
+ (license license:bsd-3)))