summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2020-02-29 11:19:28 -0600
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:17 +0200
commit075290841503d96237a8eabc60fba150b40bef4f (patch)
treee1168e0922ca986ea8d8f44f0b3b0f8d4f237b48
parent276ddb02b5c59c2b819e306e4d592c5674bef453 (diff)
downloadpatches-075290841503d96237a8eabc60fba150b40bef4f.tar
patches-075290841503d96237a8eabc60fba150b40bef4f.tar.gz
gnu: Add python-matrix-synapse-ldap3.
* gnu/packages/matrix.scm: New file. (python-matrix-synapse-ldap3): New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Add matrix.scm. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/matrix.scm52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 77696633d2..cf588e5948 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -343,6 +343,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/marst.scm \
%D%/packages/mate.scm \
%D%/packages/maths.scm \
+ %D%/packages/matrix.scm \
%D%/packages/maven.scm \
%D%/packages/mc.scm \
%D%/packages/mcrypt.scm \
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
new file mode 100644
index 0000000000..693cd98631
--- /dev/null
+++ b/gnu/packages/matrix.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages matrix)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (guix build-system python)
+ #:use-module (guix download)
+ #:use-module (guix packages))
+
+(define-public python-matrix-synapse-ldap3
+ (package
+ (name "python-matrix-synapse-ldap3")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "matrix-synapse-ldap3" version))
+ (sha256
+ (base32
+ "01bms89sl16nyh9f141idsz4mnhxvjrc3gj721wxh1fhikps0djx"))))
+ (build-system python-build-system)
+ (arguments
+ ;; tests require synapse, creating a circular dependency.
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-twisted" ,python-twisted)
+ ("python-ldap3" ,python-ldap3)
+ ("python-service-identity" ,python-service-identity)))
+ (home-page "https://github.com/matrix-org/matrix-synapse-ldap3")
+ (synopsis "LDAP3 auth provider for Synapse")
+ (description
+ "This package allows Synapse to use LDAP as a password provider.
+This lets users log in to Synapse with their username and password from
+an LDAP server.")
+ (license license:asl2.0)))