summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2020-02-29 11:10:35 -0600
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 20:55:15 +0200
commit039c5499002bfc2294927bfd7c8c7f3b08cfce2c (patch)
tree666766f81115a6747844d6f5dd568d5dd955893a
parentaf1f7a3279bc7852de138122c267b70e1603a9c0 (diff)
downloadpatches-039c5499002bfc2294927bfd7c8c7f3b08cfce2c.tar
patches-039c5499002bfc2294927bfd7c8c7f3b08cfce2c.tar.gz
gnu: Add python-daemonize.
* gnu/packages/python-xyz.scm (python-daemonize): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b31f2ff58a..b37294fcf0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18835,3 +18835,19 @@ rotate keys
key.
@end itemize")
(license license:asl2.0)))
+
+(define-public python-daemonize
+ (package
+ (name "python-daemonize")
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "daemonize" version))
+ (sha256
+ (base32 "1hwbl3gf9fdds9sc14zgjyjisjvxidrvqc11xlbb0b6jz17nw0nx"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/thesharp/daemonize")
+ (synopsis "Library for writing system daemons in Python")
+ (description "Daemonize is a library for writing system daemons in Python.")
+ (license license:expat)))