summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2020-04-01 10:32:07 -0400
committerChristopher Baines <mail@cbaines.net>2020-04-01 18:28:40 +0100
commit63406c0bfd0d016098ef593dcc8bfc412df36bea (patch)
treecb96b38d47622fc26ede2b1093f953c65e444e6d
parent475d5d8d159298b3f275ceda24d3754be1eeb9b8 (diff)
downloadpatches-63406c0bfd0d016098ef593dcc8bfc412df36bea.tar
patches-63406c0bfd0d016098ef593dcc8bfc412df36bea.tar.gz
gnu: Add gnome-chess
* gnu/packages/games.scm (gnome-chess): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/games.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e818b851f4..8a24dad33d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -49,6 +49,7 @@
;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;; Copyright © 2020 Vitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>
+;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1095,6 +1096,46 @@ destroying an ancient book using a special wand.")
;; license. The whole package is released under GPLv3+.
(license license:gpl3+)))
+(define-public gnome-chess
+ (package
+ (name "gnome-chess")
+ (version "3.36.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1a9fgi749gy1f60vbcyrqqkab9vqs42hji70q73k1xx8rv0agmg0"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))
+ #t)))))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("librsvg" ,librsvg)))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin") ; for desktop-file-validate and appstream-util
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (home-page "https://wiki.gnome.org/Apps/Chess")
+ (synopsis "Chess board for GNOME")
+ (description "GNOME Chess provides a 2D board for playing chess games
+against human or computer players. It supports loading and saving games in
+Portable Game Notation. To play against a computer, install a chess engine
+such as chess or stockfish.")
+ (license license:gpl3+)))
+
(define-public gnubg
(package
(name "gnubg")