summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-01 19:04:32 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-01 19:05:00 +0200
commit475d5d8d159298b3f275ceda24d3754be1eeb9b8 (patch)
treebd09bc1b50be884b42f01f7426b6e5971cd26ac7
parent079ffbcfaf26826adcee9bb3084794c033416d37 (diff)
downloadpatches-475d5d8d159298b3f275ceda24d3754be1eeb9b8.tar
patches-475d5d8d159298b3f275ceda24d3754be1eeb9b8.tar.gz
gnu: netpbm: Delete files natively.
* gnu/packages/netpbm.scm (netpbm)[arguments]: Delete files with DELETE-FILE-RECURSIVELY instead of invoking ‘rm’.
-rw-r--r--gnu/packages/netpbm.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/netpbm.scm b/gnu/packages/netpbm.scm
index af005c6aec..c88b5a9dff 100644
--- a/gnu/packages/netpbm.scm
+++ b/gnu/packages/netpbm.scm
@@ -171,12 +171,10 @@
(apply invoke "make" "package"
(string-append "pkgdir=" out) make-flags)
;; Remove superfluous files.
- (invoke "rm" "-r" (string-append out "/link"))
- (invoke "rm" "-r" (string-append out "/misc"))
(with-directory-excursion out
- (for-each delete-file
- '("config_template" "pkginfo" "README"
- "VERSION")))
+ (for-each delete-file-recursively
+ '("config_template" "pkginfo" "README" "VERSION"
+ "link/" "misc/")))
#t))))))
(synopsis "Toolkit for manipulation of images")
(description