summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-04-01 10:43:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-01 10:43:44 +0200
commit31e47945d37a738fccbb5c7e304f01ccfdd45a68 (patch)
tree128a696026d83d907629b963b19cd2d2c70f89d5
parent61e10fa8394307f461922a1cb55897422c38ce75 (diff)
downloadpatches-31e47945d37a738fccbb5c7e304f01ccfdd45a68.tar
patches-31e47945d37a738fccbb5c7e304f01ccfdd45a68.tar.gz
gnu: Add emacs-elf-mode.
* gnu/packages/emacs-xyz.scm (emacs-elf-mode): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b7aa64e733..7224066d69 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1824,6 +1824,27 @@ Using emacs-direnv means that programs started from Emacs will use the
environment set through Direnv.")
(license license:gpl3+)))
+(define-public emacs-elf-mode
+ (package
+ (name "emacs-elf-mode")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/abo-abo/elf-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cbvjbk2893ag1iy8ggixpirfiyhssm7fii96hb9jqdz874cdl0k"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/abo-abo/elf-mode")
+ (synopsis "Show symbol list when opening a binary file in Emacs")
+ (description "This Emacs package provides a command showing the symbols
+that the binary uses instead of the actual binary contents.")
+ (license license:gpl3+)))
+
(define-public emacs-ggtags
(package
(name "emacs-ggtags")