summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-04-02 10:10:17 +0200
committerGuix Patches Tester <>2020-04-02 09:12:09 +0100
commit55da8318362ef41fb7299c3732f262973ef26344 (patch)
treed39b4706c9d3f02781a4b4da49e41d2cb39d9431
parente7228f0cfaf7b09f895111886a4df6aa53812ecd (diff)
downloadpatches-series-3405.tar
patches-series-3405.tar.gz
gnu: Set JAVA_HOME for all Java development kits.series-3405
* gnu/packages/java.scm (icedtea-6, icedtea-7, openjdk9)[native-search-paths]: Set JAVA_HOME to "jre". This fixes issues for which the Java tooling could not find Jars, e.g. tools.jar.
-rw-r--r--gnu/packages/java.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 4d305aac49..ca6c64fc1e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1078,6 +1078,10 @@ machine.")))
(sha256
(base32
"0835lkw8vib1xhp8lxnybhlvzdh699hbi4mclxanydjk63zbpxk0"))))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "JAVA_HOME")
+ (files '("jre")))))
(home-page "http://icedtea.classpath.org")
(synopsis "Java development kit")
(description
@@ -1620,6 +1624,10 @@ bootstrapping purposes.")
("lcms" ,lcms)
("zlib" ,zlib)
("gtk" ,gtk+-2)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "JAVA_HOME")
+ (files '("jre")))))
(home-page "http://icedtea.classpath.org")
(synopsis "Java development kit")
(description
@@ -1923,6 +1931,10 @@ new Date();"))
("unzip" ,unzip)
("which" ,which)
("zip" ,zip)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "JAVA_HOME")
+ (files '("jre")))))
(home-page "https://openjdk.java.net/projects/jdk9/")
(synopsis "Java development kit")
(description